dev-libs/libressl: stable 2.8.3 for sparc, bug #653516
[gentoo.git] / dev-libs / libressl / libressl-2.6.5.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools multilib-minimal
7
8 DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
9 HOMEPAGE="https://www.libressl.org/"
10 SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
11
12 LICENSE="ISC openssl"
13 # Reflects ABI of libcrypto.so and libssl.so.  Since these can differ,
14 # we'll try to use the max of either.  However, if either change between
15 # versions, we have to change the subslot to trigger rebuild of consumers.
16 SLOT="0/44"
17 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
18 IUSE="+asm static-libs test"
19 REQUIRED_USE="test? ( static-libs )"
20
21 RDEPEND="!dev-libs/openssl:0"
22 DEPEND="${RDEPEND}"
23 PDEPEND="app-misc/ca-certificates"
24
25 PATCHES=( "${FILESDIR}/libressl-2.6.4-hppa-asm.patch" )
26
27 src_prepare() {
28         touch crypto/Makefile.in
29
30         sed -i \
31                 -e '/^[ \t]*CFLAGS=/s#-g ##' \
32                 -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
33                 -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
34                 -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
35                 -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
36                 -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
37                 configure || die "fixing CFLAGS failed"
38
39         default
40         eautoreconf
41 }
42
43 multilib_src_configure() {
44         ECONF_SOURCE="${S}" econf \
45                 $(use_enable asm) \
46                 $(use_enable static-libs static)
47 }
48
49 multilib_src_test() {
50         emake check
51 }
52
53 multilib_src_install_all() {
54         einstalldocs
55         find "${D}" -name '*.la' -exec rm -f {} + || die
56 }