dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / dev-libs / librelp / librelp-1.5.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit autotools python-any-r1
8
9 DESCRIPTION="An easy to use library for the RELP protocol"
10 HOMEPAGE="https://www.rsyslog.com/librelp/"
11 SRC_URI="https://download.rsyslog.com/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3+ doc? ( FDL-1.3 )"
14
15 # subslot = soname version
16 SLOT="0/0.5.0"
17
18 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
19 IUSE="debug doc +ssl +gnutls libressl openssl static-libs test"
20 REQUIRED_USE="ssl? ( ^^ ( gnutls openssl ) )"
21
22 RDEPEND="
23         ssl? (
24                 gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
25                 openssl? (
26                         !libressl? ( dev-libs/openssl:0= )
27                         libressl? ( dev-libs/libressl:0= )
28                 )
29         )"
30 DEPEND="${RDEPEND}
31         test? ( ${PYTHON_DEPS} )
32         virtual/pkgconfig"
33
34 RESTRICT="!test? ( test )"
35
36 pkg_setup() {
37         use test && python-any-r1_pkg_setup
38 }
39
40 src_prepare() {
41         sed -i \
42                 -e 's/ -g"/"/g' \
43                 configure.ac || die "sed failed"
44
45         default
46
47         eautoreconf
48 }
49
50 src_configure() {
51         local myeconfargs=(
52                 --disable-valgrind
53                 $(use_enable debug)
54                 $(use_enable gnutls tls)
55                 $(use_enable openssl tls-openssl)
56                 $(use_enable static-libs static)
57         )
58
59         econf "${myeconfargs[@]}"
60 }
61
62 src_test() {
63         emake -j1 check
64 }
65
66 src_install() {
67         local DOCS=( ChangeLog )
68         use doc && local HTML_DOCS=( doc/relp.html )
69         default
70
71         if ! use static-libs; then
72                 find "${D}" -name '*.la' -delete || die
73         fi
74 }