*/*: downgrade m68k down to ~m68k
[gentoo.git] / dev-libs / libpipeline / libpipeline-1.5.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="a pipeline manipulation library"
7 HOMEPAGE="http://libpipeline.nongnu.org/"
8 SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
13 IUSE="static-libs test"
14 RESTRICT="!test? ( test )"
15
16 DEPEND="virtual/pkgconfig
17         test? ( dev-libs/check )"
18
19 src_configure() {
20         econf $(use_enable static-libs static)
21 }
22
23 src_install() {
24         default
25         find "${ED}" -name "*.la" -delete || die
26 }