Drop $Header$ per council decision in bug #611234.
[gentoo.git] / dev-libs / libpfm / libpfm-4.8.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit multilib toolchain-funcs
7
8 DESCRIPTION="Hardware-based performance monitoring interface for Linux"
9 HOMEPAGE="http://perfmon2.sourceforge.net"
10 SRC_URI="mirror://sourceforge/perfmon2/${PN}4/${P}.tar.gz"
11
12 LICENSE="GPL-2 MIT"
13 SLOT="0/4"
14 KEYWORDS="~amd64 ~ppc64 ~x86"
15 IUSE="static-libs"
16
17 DEPEND=""
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         sed -e "s:SLDFLAGS=:SLDFLAGS=\$(LDFLAGS) :g" \
22                 -i lib/Makefile || die
23         sed -e "s:LIBDIR=\$(PREFIX)/lib:LIBDIR=\$(PREFIX)/$(get_libdir):g" \
24                 -i config.mk || die
25 }
26
27 src_compile() {
28         emake CC=$(tc-getCC)
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" LDCONFIG=true PREFIX="${EPREFIX}/usr"  install
33         use static-libs || find "${ED}" -name '*.a' -exec rm -f '{}' +
34         dodoc README
35 }