da40287013ddff374ef12999cd7421c6451f565b
[gentoo.git] / dev-libs / libp11 / libp11-0.4.10.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
7 HOMEPAGE="https://github.com/opensc/libp11/wiki"
8 SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86"
13 IUSE="libressl bindist doc static-libs"
14
15 RDEPEND="
16         !libressl? ( dev-libs/openssl:0=[bindist=] )
17         libressl? ( >=dev-libs/libressl-2.8:0= )"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig
20         doc? ( app-doc/doxygen )"
21
22 src_configure() {
23         econf \
24                 --enable-shared \
25                 $(use_enable static-libs static) \
26                 $(use_enable doc api-doc)
27 }
28
29 src_install() {
30         default
31         find "${D}" -name '*.la' -delete || die
32 }