Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / dev-libs / libmacaroons / libmacaroons-0.3.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit eutils python-single-r1
10
11 # Tests can't function after 2014-12-31 ...
12 RESTRICT="test"
13
14 DESCRIPTION="Hyperdex macaroons support library"
15
16 HOMEPAGE="http://hyperdex.org"
17 SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
18 LICENSE="BSD"
19 SLOT="0"
20 KEYWORDS="~amd64"
21
22 IUSE="test +python"
23
24 RDEPEND="dev-libs/libsodium
25         dev-libs/json-c"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
28
29 REQUIRED_USE="test? ( python )"
30
31 src_prepare() {
32         use python && python-single-r1_pkg_setup
33 }
34
35 src_configure() {
36         econf $(use_enable python python-bindings)
37 }
38
39 src_test() {
40         emake -j1 check || die
41 }