dev-libs/liblogging: arm stable, bug #645870
[gentoo.git] / dev-libs / liblogging / liblogging-1.0.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit autotools
7
8 DESCRIPTION="Liblogging is an easy to use, portable, open source library for system logging"
9 HOMEPAGE="http://www.liblogging.org"
10 SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
11
12 LICENSE="BSD-2"
13 SLOT="0/0"
14 KEYWORDS="amd64 arm ~arm64 hppa x86"
15 IUSE="rfc3195 static-libs +stdlog systemd"
16
17 RDEPEND="systemd? ( sys-apps/systemd )"
18
19 DEPEND="
20         ${RDEPEND}
21         virtual/pkgconfig
22 "
23
24 DOCS=( ChangeLog )
25
26 src_prepare() {
27         default
28
29         eautoreconf
30 }
31
32 src_configure() {
33         local myeconfargs=(
34                 $(use_enable rfc3195)
35                 $(use_enable stdlog)
36                 $(use_enable systemd journal)
37         )
38
39         econf "${myeconfargs[@]}"
40 }
41
42 src_install() {
43         default
44
45         find "${ED}"usr/lib* -name '*.la' -delete || die
46 }