Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-libs / liblist / liblist-2.4.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit autotools-utils multilib
8
9 DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
10 HOMEPAGE="http://ohnopub.net/liblist"
11 SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
16 IUSE="doc examples static-libs"
17
18 RDEPEND="doc? ( media-gfx/transfig
19                 dev-texlive/texlive-metapost
20                 virtual/latex-base )"
21 DEPEND="${RDEPEND}"
22
23 src_configure() {
24         local myeconfargs=(
25                 --docdir="${EPREFIX}"/usr/share/doc/${PF}
26                 $(use_enable doc docs)
27                 $(use_enable examples)
28         )
29
30         autotools-utils_src_configure
31 }
32
33 src_install() {
34         autotools-utils_src_install
35
36         dodoc README
37
38         if use examples; then
39                 insinto /usr/share/doc/${PF}/examples
40                 doins examples/{*.c,Makefile,README}
41                 insinto /usr/share/doc/${PF}/examples/cache
42                 doins examples/cache/{*.c,README}
43         fi
44
45         docompress -x /usr/share/doc/${PF}/{list.0,paper.dvi,examples}
46 }
47
48 pkg_postinst() {
49         elog "Note that man pages for this package have been renamed to avoid"
50         elog "name collisions with some system functions. However, the libs"
51         elog "and header files have not been changed."
52         elog "The new names are liblist, lcache, liblist_queue, and liblist_stack."
53 }