Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-libs / liblist / liblist-2.3.1-r1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=3
6
7 inherit multilib
8
9 DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
10 HOMEPAGE="http://ohnopub.net/liblist"
11 SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux"
16 IUSE="doc examples static-libs"
17
18 DEPEND="doc? ( media-gfx/transfig
19         dev-texlive/texlive-metapost
20         virtual/latex-base )"
21
22 src_configure() {
23         econf --docdir="${EPREFIX}"/usr/share/doc/${PF} \
24                 $(use_enable doc docs) \
25                 $(use_enable examples) \
26                 $(use_enable static-libs static)
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die
31
32         dodoc README || die
33
34         if use examples; then
35                 insinto /usr/share/doc/${PF}/examples
36                 doins examples/{*.c,Makefile,README} || die
37                 insinto /usr/share/doc/${PF}/examples/cache
38                 doins examples/cache/{*.c,README} || die
39         fi
40
41         if ! use static-libs; then
42                 rm -v "${ED}"/usr/$(get_libdir)/liblist.la || die
43                 if use examples; then
44                         rm -v "${ED}"/usr/$(get_libdir)/libcache.la || die
45                 fi
46         fi
47 }
48
49 pkg_postinst() {
50         elog "Note the man pages for this package have been renamed to avoid"
51         elog "name collisions with some system functions, however, the libs"
52         elog "and header files have not been changed."
53         elog "The new names are llist, lcache, lqueue, and lstack."
54 }