dev-libs/libmaxminddb: arm64 stable
[gentoo.git] / dev-libs / libksba / libksba-1.3.5-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="X.509 and CMS (PKCS#7) library"
7 HOMEPAGE="http://www.gnupg.org/related_software/libksba"
8 SRC_URI="mirror://gnupg/libksba/${P}.tar.bz2"
9
10 LICENSE="LGPL-3+ GPL-2+ GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 IUSE="static-libs"
14
15 RDEPEND=">=dev-libs/libgpg-error-1.8"
16 DEPEND="${RDEPEND}"
17
18 src_configure() {
19         econf \
20                 $(use_enable static-libs static) \
21                 GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
22                 LIBGCRYPT_CONFIG="${EROOT}/usr/bin/${CHOST}-libgcrypt-config" \
23                 $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
24 }
25
26 src_install() {
27         default
28         # ppl need to use lib*-config for --cflags and --libs
29         find "${D}" -name '*.la' -delete || die
30 }