dev-libs/libixion: amd64 stable wrt bug #600038
[gentoo.git] / dev-libs / libixion / libixion-0.11.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
8
9 PYTHON_COMPAT=( python{3_4,3_5} )
10
11 [[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
12 inherit eutils python-single-r1 ${GITECLASS}
13 unset GITECLASS
14
15 DESCRIPTION="General purpose formula parser & interpreter"
16 HOMEPAGE="https://gitlab.com/ixion/ixion"
17 [[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
18
19 LICENSE="MIT"
20 SLOT="0/0.11" # based on SONAME of libixion.so
21 [[ ${PV} == 9999 ]] || \
22 KEYWORDS="amd64 ~arm ~ppc ~x86"
23 IUSE="python static-libs"
24
25 RDEPEND="
26         dev-libs/boost:=[threads]
27         python? ( ${PYTHON_DEPS} )
28 "
29 DEPEND="${RDEPEND}
30         >=dev-util/mdds-1.2.0:1=
31 "
32
33 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
34
35 pkg_setup() {
36         use python && python-single-r1_pkg_setup
37 }
38
39 src_prepare() {
40         eapply_user
41         [[ ${PV} == 9999 ]] && eautoreconf
42 }
43
44 src_configure() {
45         econf \
46                 $(use_enable python) \
47                 $(use_enable static-libs static)
48 }
49
50 src_install() {
51         default
52
53         prune_libtool_files --all
54 }