9be2116e552eba8e5ab530300d95829871dab4e1
[gentoo.git] / dev-libs / libisofs / libisofs-1.4.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit eutils
8
9 DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
10 HOMEPAGE="http://libburnia-project.org/"
11 SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="acl debug static-libs verbose-debug xattr zlib"
17
18 RDEPEND="acl? ( virtual/acl )
19         xattr? ( sys-apps/attr )
20         zlib? ( sys-libs/zlib )"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_configure() {
25         econf \
26         $(use_enable static-libs static) \
27         $(use_enable debug) \
28         $(use_enable verbose-debug) \
29         $(use_enable acl libacl) \
30         $(use_enable xattr) \
31         $(use_enable zlib) \
32         --disable-libjte \
33         --disable-ldconfig-at-install
34 }
35
36 src_install() {
37         default
38
39         dodoc Roadmap doc/{*.txt,Tutorial}
40
41         prune_libtool_files --all
42 }