dev-lisp/sbcl: Updating ebuilds to EAPI 6
[gentoo.git] / dev-libs / libinput / libinput-0.9.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils
8
9 DESCRIPTION="Library to handle input devices in Wayland"
10 HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
11 SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
12
13 # License appears to be a variant of libtiff
14 LICENSE="libtiff"
15 SLOT="0/7"
16 KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86"
17 IUSE=""
18 RESTRICT="test"
19
20 RDEPEND="
21         >=dev-libs/libevdev-0.4
22         >=sys-libs/mtdev-1.1
23         virtual/libudev
24 "
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig
27 "
28
29 src_configure() {
30         # Doc handling in kinda strange but everything
31         # is available in the tarball already.
32         sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
33                 -i Makefile.am Makefile.in || die
34 }
35
36 src_configure() {
37         # gui can be built but will not be installed
38         # building documentation silently fails with graphviz syntax errors
39         econf \
40                 --disable-documentation \
41                 --disable-event-gui \
42                 --disable-tests
43 }
44
45 src_install() {
46         emake install DESTDIR="${D}" || die
47         dodoc -r doc/html
48         prune_libtool_files
49 }