Merge game-action/minetest: Version bump to 0.4.13
[gentoo.git] / dev-libs / libiconv / libiconv-1.14.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit libtool toolchain-funcs
8
9 DESCRIPTION="GNU charset conversion library for libc which doesn't implement it"
10 HOMEPAGE="https://www.gnu.org/software/libiconv/"
11 SRC_URI="mirror://gnu/libiconv/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 arm ~mips ppc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
16 IUSE=""
17
18 DEPEND="!sys-libs/glibc
19         !sys-apps/man-pages"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23         # Make sure that libtool support is updated to link "the linux way"
24         # on FreeBSD.
25         elibtoolize
26 }
27
28 src_configure() {
29         # Disable NLS support because that creates a circular dependency
30         # between libiconv and gettext
31         econf \
32                 --docdir="\$(datarootdir)/doc/${PF}/html" \
33                 --disable-nls \
34                 --enable-shared \
35                 --enable-static
36 }
37
38 src_install() {
39         default
40
41         # Install in /lib as utils installed in /lib like gnutar
42         # can depend on this
43         gen_usr_ldscript -a iconv charset
44 }