dev-libs/libical: ppc64 stable wrt bug #620842
[gentoo.git] / dev-libs / libical / libical-1.0.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit cmake-utils
6
7 DESCRIPTION="An implementation of basic iCAL protocols"
8 HOMEPAGE="https://github.com/libical/libical"
9 SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10
11 # FIGURE OUT: Why ebuild for 1.0 was marked || ( MPL-1.1 LGPL-2 ) against what COPYING file says?
12 LICENSE="|| ( MPL-1.0 LGPL-2.1 )"
13 SLOT="0/1"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
15 IUSE="doc examples introspection static-libs"
16
17 RDEPEND="introspection? ( dev-libs/gobject-introspection )"
18 DEPEND="${RDEPEND}
19         dev-lang/perl"
20
21 DOCS=(
22         AUTHORS ReadMe.txt ReleaseNotes.txt TEST THANKS TODO
23         doc/{AddingOrModifyingComponents,UsingLibical}.txt
24 )
25
26 src_configure() {
27         local mycmakeargs=( $(cmake-utils_use introspection GOBJECT_INTROSPECTION) )
28         use static-libs || mycmakeargs+=( -DSHARED_ONLY=ON )
29         cmake-utils_src_configure
30 }
31
32 src_compile() {
33         cmake-utils_src_compile -j1
34 }
35
36 src_install() {
37         cmake-utils_src_install
38
39         if use examples; then
40                 rm examples/Makefile* examples/CMakeLists.txt
41                 insinto /usr/share/doc/${PF}/examples
42                 doins examples/*
43         fi
44 }