dev-libs/libgweather: 3.32.2 fix patch name
[gentoo.git] / dev-libs / libgweather / libgweather-3.32.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 VALA_USE_DEPEND="vapigen"
6
7 inherit gnome.org gnome2-utils meson vala xdg
8
9 DESCRIPTION="Location and timezone database and weather-lookup library"
10 HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
11
12 LICENSE="GPL-2+"
13 SLOT="2/3-15" # subslot = 3-(libgweather-3 soname suffix)
14
15 IUSE="glade gtk-doc +introspection +vala"
16 REQUIRED_USE="vala? ( introspection )"
17
18 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
19
20 RDEPEND="
21         >=dev-libs/glib-2.44.0:2
22         >=x11-libs/gtk+-3.13.5:3[introspection?]
23         >=net-libs/libsoup-2.44:2.4
24         >=dev-libs/libxml2-2.6.0:2
25         sci-geosciences/geocode-glib
26         >=sys-libs/timezone-data-2010k
27
28         glade? ( >=dev-util/glade-3.16:3.10 )
29         introspection? ( >=dev-libs/gobject-introspection-1.54:= )
30 "
31 DEPEND="${RDEPEND}"
32 BDEPEND="
33         dev-util/glib-utils
34         gtk-doc? ( >=dev-util/gtk-doc-1.11
35                 app-text/docbook-xml-dtd:4.3 )
36         >=sys-devel/gettext-0.19.8
37         virtual/pkgconfig
38         $(vala_depend)
39 "
40
41 PATCHES=(
42         "${FILESDIR}"/3.32.1-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
43 )
44
45 src_prepare() {
46         xdg_src_prepare
47         vala_src_prepare
48 }
49
50 src_configure() {
51         local emesonargs=(
52                 $(meson_use glade glade_catalog)
53                 $(meson_use vala enable_vala)
54                 $(meson_use gtk-doc gtk_doc)
55                 $(meson_use introspection)
56         )
57         meson_src_configure
58 }
59
60 pkg_postinst() {
61         xdg_pkg_postinst
62         gnome2_schemas_update
63 }
64
65 pkg_postrm() {
66         xdg_pkg_postrm
67         gnome2_schemas_update
68 }