2ba6b5b549035e6d9c41bb1555a04e369c671cb1
[gentoo.git] / dev-libs / libgweather / libgweather-3.16.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="no"
7 VALA_MIN_API_VERSION="0.18"
8 VALA_USE_DEPEND="vapigen"
9
10 inherit gnome2 vala
11
12 DESCRIPTION="Library to access weather information from online services"
13 HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
14
15 LICENSE="GPL-2+"
16 SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
17 IUSE="glade +introspection vala"
18 REQUIRED_USE="vala? ( introspection )"
19
20 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
21
22 COMMON_DEPEND="
23         >=x11-libs/gtk+-3.13.5:3[introspection?]
24         >=dev-libs/glib-2.35.1:2
25         >=net-libs/libsoup-2.34:2.4
26         >=dev-libs/libxml2-2.6.0
27         sci-geosciences/geocode-glib
28         >=sys-libs/timezone-data-2010k
29
30         glade? ( >=dev-util/glade-3.16:3.10 )
31         introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
32 "
33 RDEPEND="${COMMON_DEPEND}
34         !<gnome-base/gnome-applets-2.22.0
35 "
36 DEPEND="${COMMON_DEPEND}
37         >=dev-util/gtk-doc-am-1.11
38         >=dev-util/intltool-0.50
39         >=sys-devel/gettext-0.18
40         virtual/pkgconfig
41         vala? ( $(vala_depend) )
42 "
43
44 src_prepare() {
45         use vala && vala_src_prepare
46         gnome2_src_prepare
47 }
48
49 src_configure() {
50         DOCS="AUTHORS MAINTAINERS NEWS README"
51         gnome2_src_configure \
52                 --disable-static \
53                 $(use_enable glade glade-catalog) \
54                 $(use_enable introspection) \
55                 $(use_enable vala)
56 }