dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / libgee / libgee-0.20.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2
7
8 DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
9 HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
10
11 LICENSE="LGPL-2.1+"
12 SLOT="0.8/2"
13 KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~x86-linux"
14 IUSE="+introspection"
15
16 # FIXME: add doc support, requires valadoc
17 RDEPEND="
18         >=dev-libs/glib-2.36:2
19         introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
20 "
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23 "
24
25 src_configure() {
26         gnome2_src_configure \
27                 $(use_enable introspection) \
28                 VALAC="$(type -P false)"
29 }