*/*: Replace virtual/libgudev with dev-libs/libgudev
[gentoo.git] / dev-libs / libgaminggear / libgaminggear-0.15.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils xdg
7
8 DESCRIPTION="Provides functionality for gaming input devices"
9
10 HOMEPAGE="https://sourceforge.net/projects/libgaminggear/"
11 SRC_URI="mirror://sourceforge/libgaminggear/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc"
16
17 RDEPEND="
18         >=dev-db/sqlite-3.17:3
19         dev-libs/glib:2
20         media-libs/libcanberra
21         x11-libs/cairo
22         x11-libs/gtk+:2
23         x11-libs/libnotify
24         x11-libs/pango
25 "
26
27 DEPEND="
28         ${RDEPEND}
29         dev-libs/libgudev
30 "
31 BDEPEND="
32         dev-util/glib-utils
33         doc? ( app-doc/doxygen )
34 "
35
36 PATCHES=(
37         "${FILESDIR}"/${PN}-0.10.0-doc.patch
38 )
39
40 # Required because xdg.eclass overrides src_prepare() from cmake-utils.eclass
41 src_prepare() {
42         cmake-utils_src_prepare
43 }
44
45 src_configure() {
46         mycmakeargs=(
47                 -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
48                 -DWITH_DOC="$(usex doc)"
49         )
50         cmake-utils_src_configure
51 }
52
53 src_install() {
54         cmake-utils_src_install
55 }
56
57 pkg_preinst() {
58         xdg_pkg_preinst
59 }
60
61 pkg_postinst() {
62         xdg_pkg_postinst
63 }
64
65 pkg_postrm() {
66         xdg_pkg_postrm
67 }