media-libs/portaudio: Version bump
[gentoo.git] / dev-libs / libg15 / libg15-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 ESVN_PROJECT=g15tools/trunk
7 ESVN_REPO_URI="https://svn.code.sf.net/p/g15tools/code/trunk/${PN}"
8
9 inherit subversion base eutils autotools
10
11 DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
12 HOMEPAGE="http://g15tools.sourceforge.net/"
13 [[ $PV = *9999* ]] || SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 DEPEND="=virtual/libusb-0*"
21 RDEPEND=${DEPEND}
22
23 DOCS=( AUTHORS README ChangeLog )
24
25 PATCHES=( "${FILESDIR}"/g15tools.patch )
26
27 src_unpack() {
28         if [[ ${PV} = *9999* ]]; then
29                 subversion_src_unpack
30         fi
31 }
32
33 src_prepare() {
34         if [[ ${PV} = *9999* ]]; then
35                 subversion_wc_info
36         fi
37         base_src_prepare
38         if [[ ${PV} = *9999* ]]; then
39                 eautoreconf
40         fi
41 }
42
43 src_configure() {
44         econf \
45                 --disable-static
46 }
47
48 src_install() {
49         default
50
51         find "${ED}" -name '*.la' -exec rm -f {} +
52 }