dev-libs/icu-layoutex: sparc stable wrt bug #716822
[gentoo.git] / dev-libs / libevocosm / libevocosm-3.3.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils ltprune
7
8 DESCRIPTION="A C++ framework for evolutionary computing"
9 HOMEPAGE="http://www.coyotegulch.com/products/libevocosm/"
10 SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
15
16 IUSE="doc static-libs"
17
18 RDEPEND="dev-libs/libcoyotl
19         dev-libs/libbrahe"
20 DEPEND="${RDEPEND}
21         doc? ( app-doc/doxygen )"
22
23 DOCS=( AUTHORS ChangeLog NEWS README )
24
25 src_prepare() {
26         epatch "${FILESDIR}/${P}-gcc47.patch"
27         epatch_user
28 }
29
30 src_configure() {
31         export ac_cv_prog_HAVE_DOXYGEN="false"
32         econf $(use_enable static-libs static)
33 }
34
35 src_compile() {
36         emake
37
38         if use doc ; then
39                 cd docs
40                 doxygen libevocosm.doxygen || die "generating docs failed"
41         fi
42 }
43
44 src_install() {
45         default
46         prune_libtool_files
47         use doc && dohtml docs/html/*
48 }