dev-libs/kuserfeedback: x86 stable wrt bug #721452
[gentoo.git] / dev-libs / libevdev / libevdev-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit meson multilib-minimal python-any-r1
9
10 DESCRIPTION="Handler library for evdev events"
11 HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
12
13 if [[ ${PV} == 9999* ]] ; then
14         EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
15         inherit git-r3
16 else
17         SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
18         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
19 fi
20
21 LICENSE="MIT"
22 SLOT="0"
23 IUSE="doc test"
24
25 DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
26 BDEPEND="
27         ${PYTHON_DEPS}
28         doc? ( app-doc/doxygen )
29         virtual/pkgconfig[${MULTILIB_USEDEP}]
30 "
31 RESTRICT="!test? ( test )"
32
33 multilib_src_configure() {
34         local emesonargs=(
35                 $(meson_feature doc documentation)
36                 $(meson_feature test tests)
37         )
38         meson_src_configure
39 }
40
41 multilib_src_compile() {
42         meson_src_compile
43 }
44
45 multilib_src_test() {
46         meson_src_test
47 }
48
49 multilib_src_install() {
50         meson_src_install
51 }
52
53 multilib_src_install_all() {
54         if use doc; then
55                 local HTML_DOCS=( doc/html/. )
56                 einstalldocs
57         fi
58 }