dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-libs / libev / libev-4.33.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools eutils multilib-minimal
7
8 DESCRIPTION="A high-performance event loop/event model with lots of feature"
9 HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
10 SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
11         http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
12
13 LICENSE="|| ( BSD GPL-2 )"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
16 IUSE="static-libs"
17
18 DOCS=( Changes README )
19
20 # bug #411847
21 PATCHES=( "${FILESDIR}/${PN}-4.25-pc.patch" )
22
23 src_prepare() {
24         default
25         sed -i -e "/^include_HEADERS/s/ event.h//" Makefile.am || die
26
27         eautoreconf
28 }
29
30 multilib_src_configure() {
31         ECONF_SOURCE="${S}" \
32         econf \
33                 --disable-maintainer-mode \
34                 $(use_enable static-libs static)
35 }
36
37 multilib_src_install_all() {
38         if ! use static-libs; then
39                 find "${D}" -name '*.la' -type f -delete || die
40         fi
41         einstalldocs
42 }