dev-libs/libev: dropped ~x64-freebsd ~x86-freebsd
[gentoo.git] / dev-libs / libev / libev-4.20.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils multilib-minimal
8
9 DESCRIPTION="A high-performance event loop/event model with lots of feature"
10 HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
11 SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
12         http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
13
14 LICENSE="|| ( BSD GPL-2 )"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
17 IUSE="elibc_glibc static-libs"
18
19 # Bug #283558
20 DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
21 RDEPEND="${DEPEND}"
22
23 DOCS=( Changes README )
24
25 src_prepare() {
26         sed -i -e "/^include_HEADERS/s/ event.h//" Makefile.am || die
27
28         # bug #411847
29         epatch "${FILESDIR}/${PN}-pc.patch"
30
31         epatch_user
32         eautoreconf
33 }
34
35 multilib_src_configure() {
36         ECONF_SOURCE="${S}" \
37         econf \
38                 --disable-maintainer-mode \
39                 $(use_enable static-libs static)
40 }
41
42 multilib_src_install_all() {
43         use static-libs || prune_libtool_files
44         einstalldocs
45 }