dev-libs/libestr: bump to v0.1.11
[gentoo.git] / dev-libs / libestr / libestr-0.1.11.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit autotools
7
8 DESCRIPTION="Library for some string essentials"
9 HOMEPAGE="http://libestr.adiscon.com/"
10 SRC_URI="http://libestr.adiscon.com/files/download/${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
15 IUSE="debug static-libs test"
16
17 DEPEND=""
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         default
22
23         eautoreconf
24 }
25
26 src_configure() {
27         local myeconfargs=(
28                 $(use_enable debug)
29                 $(use_enable static-libs static)
30                 $(use_enable test testbench)
31         )
32
33         econf "${myeconfargs[@]}"
34 }
35
36 src_install() {
37         default
38
39         find "${ED%/}"/usr/lib* -name '*.la' -delete || die
40 }