dev-libs/libestr: Bumped to v0.1.10
[gentoo.git] / dev-libs / libestr / libestr-0.1.10.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit autotools
8
9 DESCRIPTION="Library for some string essentials"
10 HOMEPAGE="http://libestr.adiscon.com/"
11 SRC_URI="http://libestr.adiscon.com/files/download/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~hppa ~x86"
16 IUSE="debug static-libs test"
17
18 DEPEND=""
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         default
23
24         eautoreconf
25 }
26
27 src_configure() {
28         local myeconfargs=(
29                 $(use_enable debug)
30                 $(use_enable static-libs static)
31                 $(use_enable test testbench)
32         )
33
34         econf "${myeconfargs[@]}"
35 }
36
37 src_install() {
38         default
39
40         find "${ED}"usr/lib* -name '*.la' -delete || die
41 }