dev-libs/liberasurecode: 1.6.0 bump
[gentoo.git] / dev-libs / liberasurecode / liberasurecode-1.6.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils multilib toolchain-funcs
7
8 DESCRIPTION="Erasure Code API library written in C with pluggable Erasure Code backends."
9 HOMEPAGE="https://bitbucket.org/tsg-/liberasurecode/overview"
10 SRC_URI="https://github.com/openstack/liberasurecode/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm64 ~x86"
15 IUSE="doc static-libs"
16
17 RDEPEND=""
18 DEPEND="sys-devel/autoconf
19         doc? ( app-doc/doxygen )"
20
21 src_prepare() {
22         eapply_user
23         eautoreconf
24 }
25
26 src_configure() {
27         econf \
28                 --htmldir=/usr/share/doc/${PF} \
29                 --disable-werror \
30                 $(use_enable doc doxygen) \
31                 $(use_enable static-libs static)
32 }
33
34 src_install() {
35         default
36         prune_libtool_files
37 }