dev-libs/libax25: Drop old
[gentoo.git] / dev-libs / libee / libee-0.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="An Event Expression Library inspired by CEE"
7 HOMEPAGE="http://www.libee.org"
8 SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="amd64 arm ~arm64 hppa x86 ~amd64-linux"
13 IUSE="debug"
14
15 RDEPEND="
16         dev-libs/libxml2
17         dev-libs/libestr"
18 DEPEND="${RDEPEND}"
19
20 src_configure() {
21         econf \
22                 --disable-static \
23                 --enable-testbench \
24                 $(use_enable debug)
25 }
26
27 src_compile() {
28         emake -j1
29 }
30
31 src_install() {
32         default
33
34         # no static archives
35         find "${D}" -name '*.la' -delete || die
36 }