dev-lisp/sbcl: Updating ebuilds to EAPI 6
[gentoo.git] / dev-libs / libebml / libebml-1.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 AUTOTOOLS_AUTORECONF=1
7
8 inherit autotools-utils
9
10 DESCRIPTION="Extensible binary format library (kinda like XML)"
11 HOMEPAGE="http://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
12 SRC_URI="http://dl.matroska.org/downloads/${PN}/${P}.tar.bz2"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0/4" # subslot = soname major version
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
17 IUSE="debug static-libs"
18
19 src_prepare() {
20         sed -i '/^AM_CXXFLAGS += -g/d' Makefile.am || die
21
22         autotools-utils_src_prepare
23 }
24
25 src_configure() {
26         local myeconfargs=(
27                 $(use_enable debug)
28         )
29         autotools-utils_src_configure
30 }