dev-libs/rapidjson: disable git submodules in -9999
[gentoo.git] / dev-libs / libe / libe-0.10.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 EAPI=4
4
5 inherit eutils
6
7 # bit messy at the moment, next release should fix it I hope
8 RESTRICT="test"
9
10 DESCRIPTION="Hyperdex libe support library"
11
12 HOMEPAGE="http://hyperdex.org"
13 SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17
18 IUSE=""
19
20 RDEPEND=">=dev-libs/libpo6-0.7.0"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_prepare() {
25         sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
26 }