3d6d79ec991086b6c660d62e71942492c4149d52
[gentoo.git] / dev-libs / libdivsufsort / libdivsufsort-2.0.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit cmake-utils multilib
6
7 DESCRIPTION="Suffix-sorting library (for BWT)"
8 HOMEPAGE="https://github.com/y-256/libdivsufsort"
9 SRC_URI="https://github.com/y-256/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 src_prepare() {
17         cmake-utils_src_prepare
18
19         # will appreciate saner approach, if there is any
20         sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
21                 */CMakeLists.txt || die
22 }
23
24 src_configure() {
25         local mycmakeargs=("-DBUILD_DIVSUFSORT64=ON")
26         cmake-utils_src_configure
27 }