dev-libs/libclc: Current version requires LLVM <= 5
[gentoo.git] / dev-libs / libclc / libclc-0.2.0_pre20160921.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6
7 EGIT_REPO_URI="http://llvm.org/git/${PN}.git
8         https://github.com/llvm-mirror/${PN}.git"
9 EGIT_COMMIT="520743b0b72862a987ead6213dc1a5321a2010f9"
10
11 if [[ ${PV} = 9999* ]]; then
12         GIT_ECLASS="git-r3"
13         EXPERIMENTAL="true"
14 else
15         GIT_ECLASS="vcs-snapshot"
16 fi
17
18 inherit python-any-r1 ${GIT_ECLASS}
19
20 DESCRIPTION="OpenCL C library"
21 HOMEPAGE="http://libclc.llvm.org/"
22
23 if [[ ${PV} = 9999* ]]; then
24         SRC_URI="${SRC_PATCHES}"
25 else
26         SRC_URI="https://github.com/llvm-mirror/libclc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
27                 ${SRC_PATCHES}"
28 fi
29
30 LICENSE="|| ( MIT BSD )"
31 SLOT="0"
32 KEYWORDS="amd64 x86"
33 IUSE=""
34
35 RDEPEND="
36         >=sys-devel/clang-3.9
37         >=sys-devel/llvm-3.9"
38 DEPEND="${RDEPEND}
39         ${PYTHON_DEPS}"
40
41 src_configure() {
42         ./configure.py \
43                 --with-llvm-config="$(type -P llvm-config)" \
44                 --prefix="${EPREFIX}/usr" || die
45 }
46
47 src_compile() {
48         emake VERBOSE=1
49 }