sys-fs/fatsort: Version bump to fatsort-1.6.2.605.
[gentoo.git] / dev-libs / libburn / libburn-1.5.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
7 HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
8 SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
13 IUSE="debug static-libs"
14
15 BDEPEND="
16         virtual/pkgconfig
17 "
18 RDEPEND=""
19 DEPEND="
20         ${RDEPEND}
21 "
22
23 src_configure() {
24         econf \
25         $(use_enable static-libs static) \
26         --disable-ldconfig-at-install \
27         $(use_enable debug)
28 }
29
30 src_install() {
31         default
32
33         dodoc CONTRIBUTORS doc/{comments,*.txt}
34
35         docinto cdrskin
36         dodoc cdrskin/{*.txt,README}
37         docinto cdrskin/html
38         dodoc cdrskin/cdrskin_eng.html
39
40         find "${D}" -name '*.la' -delete || die
41 }