Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / dev-libs / libburn / libburn-1.4.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
10 HOMEPAGE="http://libburnia-project.org"
11 SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="cdio debug static-libs track-src-odirect"
17
18 RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
19 DEPEND="$RDEPEND
20         virtual/pkgconfig"
21
22 src_configure() {
23         econf \
24         $(use_enable static-libs static) \
25         $(use_enable track-src-odirect) \
26         --enable-pkg-check-modules \
27         $(use_enable cdio libcdio) \
28         --disable-ldconfig-at-install \
29         $(use_enable debug)
30 }
31
32 src_install() {
33         default
34
35         dodoc CONTRIBUTORS doc/{comments,*.txt}
36
37         docinto cdrskin
38         dodoc cdrskin/{*.txt,README}
39         docinto cdrskin/html
40         dohtml cdrskin/cdrskin_eng.html
41
42         prune_libtool_files --all
43 }