dev-libs/libbson: bump to 1.13.0
[gentoo.git] / dev-libs / libbson / libbson-1.8.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A BSON utility library"
7 HOMEPAGE="https://github.com/mongodb/libbson"
8 SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="amd64 hppa ~ppc x86"
13 IUSE="debug examples static-libs"
14
15 src_configure() {
16         econf --disable-optimizations \
17                 $(use_enable debug) \
18                 $(use_enable static-libs static)
19 }
20
21 src_install() {
22         default
23
24         # Installing all the manuals conflicts with man-pages
25         doman doc/man/bson_*.3
26
27         if ! use static-libs; then
28                 find "${D}" -name '*.la' -delete || die
29         fi
30
31         if use examples; then
32                 docinto examples
33                 dodoc examples/*.c
34         fi
35
36         einstalldocs
37 }
38
39 src_test() {
40         emake test
41 }