dev-libs/libxml2: arm64 stable (bug #701020)
[gentoo.git] / dev-libs / libbase58 / libbase58-0.1.4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools
6
7 DESCRIPTION="C implementation of Bitcoin's base58 encoding"
8 HOMEPAGE="https://github.com/luke-jr/libbase58"
9 LICENSE="MIT"
10
11 SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 SLOT="0/0"
13 KEYWORDS="amd64 ~arm ~mips ~ppc ~ppc64 x86"
14 IUSE="tools"
15
16 DEPEND=""
17 RDEPEND="${DEPEND}"
18
19 src_prepare() {
20         eapply_user
21         eautoreconf
22 }
23
24 src_configure() {
25         econf \
26                 --disable-static \
27                 $(use_enable tools tool)
28 }