dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / libb64 / libb64-1.2.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Fast Base64 encoding/decoding routines"
7 HOMEPAGE="http://libb64.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
9
10 LICENSE="CC-PD"
11 # static library, so always rebuild
12 SLOT="0/${PVR}"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17
18 src_compile() {
19         # override -O3, -Werror non-sense
20         emake -C src CFLAGS="${CFLAGS} -I../include"
21 }
22
23 src_install() {
24         dolib src/libb64.a
25         insinto /usr/include
26         doins -r include/b64
27         dodoc AUTHORS BENCHMARKS CHANGELOG README
28 }