dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / libatomic_ops / libatomic_ops-7.6.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib-minimal
7
8 DESCRIPTION="Implementation for atomic memory update operations"
9 HOMEPAGE="https://github.com/ivmai/libatomic_ops/"
10 SRC_URI="https://github.com/ivmai/${PN}/releases/download/v${PV}/${P}.tar.gz"
11
12 LICENSE="MIT boehm-gc GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE=""
16
17 multilib_src_configure() {
18         local myeconfargs=(
19                 --enable-shared
20         )
21         ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
22 }
23
24 multilib_src_install() {
25         default
26         find "${ED}" -name '*.la' -delete || die
27 }