dev-libs/libatomic_ops: version bump to 7.6.0
[gentoo.git] / dev-libs / libatomic_ops / libatomic_ops-7.2d.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Implementation for atomic memory update operations"
9 HOMEPAGE="http://www.hpl.hp.com/research/linux/atomic_ops/"
10 SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV/_}.tar.gz"
11
12 LICENSE="MIT boehm-gc GPL-2+"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE=""
16
17 S=${WORKDIR}/gc-${PV/d}/libatomic_ops
18
19 src_prepare() {
20         sed -i \
21                 -e "/^pkgdatadir/s:/.*:/doc/${PF}:" \
22                 doc/Makefile.in || die
23         find -type f -exec touch -r . {} +
24 }
25
26 src_compile() {
27         emake AR="$(tc-getAR)"
28 }
29
30 src_install() {
31         default
32         find "${ED}" '(' -name COPYING -o -name LICENSING.txt ')' -delete
33 }