Merge github#925: dev-perl/M*: updates and related fixes.
[gentoo.git] / dev-libs / libatomic_ops / libatomic_ops-7.2d.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="Implementation for atomic memory update operations"
10 HOMEPAGE="http://www.hpl.hp.com/research/linux/atomic_ops/"
11 SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV/_}.tar.gz"
12
13 LICENSE="MIT boehm-gc GPL-2+"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 S=${WORKDIR}/gc-${PV/d}/libatomic_ops
19
20 src_prepare() {
21         sed -i \
22                 -e "/^pkgdatadir/s:/.*:/doc/${PF}:" \
23                 doc/Makefile.in || die
24         find -type f -exec touch -r . {} +
25 }
26
27 src_compile() {
28         emake AR="$(tc-getAR)"
29 }
30
31 src_install() {
32         default
33         find "${ED}" '(' -name COPYING -o -name LICENSING.txt ')' -delete
34 }