dev-libs/elfutils: version bump to 0.165
[gentoo.git] / dev-libs / libatasmart / libatasmart-0.19-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils
7
8 PATCH_LEVEL=2
9
10 DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
11 HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
12 SRC_URI="http://0pointer.de/public/${P}.tar.xz
13         mirror://debian/pool/main/liba/${PN}/${PN}_${PV}-${PATCH_LEVEL}.debian.tar.gz"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
18 IUSE="static-libs"
19
20 RDEPEND="virtual/udev"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 DOCS="README"
25
26 src_prepare() {
27         # https://bugs.gentoo.org/470874
28         local d="${WORKDIR}"/debian/patches
29         sed -i -e '/#/d' "${d}"/series || die
30         EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
31 }
32
33 src_configure() {
34         econf \
35                 --docdir=/usr/share/doc/${PF} \
36                 $(use_enable static-libs static)
37 }
38
39 src_install() {
40         default
41         prune_libtool_files --all
42 }