x11-themes/gtk-engines: add alpha keyword
[gentoo.git] / dev-libs / libappindicator / libappindicator-12.10.0-r300.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 VALA_MIN_API_VERSION="0.16"
7 VALA_USE_DEPEND="vapigen"
8
9 inherit autotools eutils multilib-minimal vala
10
11 DESCRIPTION="A library to allow applications to export a menu into the Unity Menu bar"
12 HOMEPAGE="https://launchpad.net/libappindicator"
13 SRC_URI="https://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
14
15 LICENSE="LGPL-2.1 LGPL-3"
16 SLOT="3"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+introspection"
19
20 RDEPEND="
21         >=dev-libs/dbus-glib-0.98[${MULTILIB_USEDEP}]
22         >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
23         >=dev-libs/libdbusmenu-0.6.2[gtk3,${MULTILIB_USEDEP}]
24         >=dev-libs/libindicator-12.10.0:3[${MULTILIB_USEDEP}]
25         >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP},introspection?]
26         introspection? ( >=dev-libs/gobject-introspection-1 )
27 "
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig[${MULTILIB_USEDEP}]
30         introspection? ( $(vala_depend) )
31 "
32
33 src_prepare() {
34         # Don't use -Werror
35         sed -i -e 's/ -Werror//' {src,tests}/Makefile.{am,in} || die
36
37         epatch "${FILESDIR}"/${P}-conditional-py-bindings.patch
38         eautoreconf
39
40         # Disable MONO for now because of https://bugs.gentoo.org/382491
41         sed -i -e '/^MONO_REQUIRED_VERSION/s:=.*:=9999:' configure || die
42 }
43
44 multilib_src_configure() {
45         if multilib_is_native_abi; then
46                 local -x VALAC VAPIGEN_VAPIDIR PKG_CONFIG_PATH
47                 use introspection && vala_src_prepare
48         fi
49
50         ECONF_SOURCE=${S} \
51         econf \
52                 --disable-silent-rules \
53                 --disable-static \
54                 --with-gtk=3 \
55                 $(multilib_native_use_enable introspection)
56 }
57
58 multilib_src_install() {
59         emake -j1 DESTDIR="${D}" install
60 }
61
62 multilib_src_install_all() {
63         dodoc AUTHORS ChangeLog
64
65         prune_libtool_files
66 }