dev-libs/kqoauth: migrate to Qt5
[gentoo.git] / dev-libs / kqoauth / kqoauth-0.98-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit qmake-utils
8
9 DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
10 HOMEPAGE="https://github.com/kypeli/kQOAuth"
11 SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="
19         dev-qt/qtcore:5
20         dev-qt/qtgui:5
21         dev-qt/qtnetwork:5
22         dev-qt/qtxml:5
23 "
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/kQOAuth-${PV}"
27
28 src_prepare() {
29         default
30
31         # prevent tests from beeing built at src_compile
32         sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
33         # respect libdir
34         sed -e 's:{INSTALL_PREFIX}/lib:[QT_INSTALL_LIBS]:g' -i src/src.pro || die "sed on src.pro failed"
35
36         sed \
37                 -e "s/TARGET = kqoauth/TARGET = kqoauth-qt5/g" \
38                 -i src/src.pro || die
39 }
40
41 src_configure() {
42         eqmake5
43 }
44
45 src_install() {
46         emake INSTALL_ROOT="${D}" install
47 }