dev-libs/judy: arm stable wrt bug #648226
[gentoo.git] / dev-libs / judy / judy-1.0.5-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools ltprune multilib-minimal
7
8 DESCRIPTION="A C library that implements a dynamic array"
9 HOMEPAGE="http://judy.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/judy/Judy-${PV}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ~ppc ppc64 ~s390 sparc x86"
15 IUSE="static-libs"
16 DOCS=( AUTHORS ChangeLog README )
17
18 src_prepare() {
19         eapply -p0 "${FILESDIR}/${P}-parallel-make.patch"
20         eapply "${FILESDIR}/${P}-gcc49.patch"
21         sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
22         eapply_user
23         eautoreconf
24         multilib_copy_sources
25 }
26
27 multilib_src_configure() {
28         ECONF_SOURCE=${BUILD_DIR} econf $(use_enable static-libs static)
29 }
30
31 multilib_src_install_all(){
32         einstalldocs
33         prune_libtool_files
34 }