dev-python/csv23: arm64 keyworded (bug #719700)
[gentoo.git] / dev-libs / jthread / jthread-1.3.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-multilib
7
8 DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
9 HOMEPAGE="http://research.edm.uhasselt.be/jori/page/CS/Jthread.html"
10 SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 x86"
15
16 IUSE="static-libs"
17
18 DOCS=( ChangeLog README.md doc/manual.tex )
19
20 src_prepare() {
21         # do not build static library, if it is not requested
22         if ! use static-libs; then
23                 sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
24         fi
25         cmake-utils_src_prepare
26 }