Merge remote-tracking branch 'github/pr/760'.
[gentoo.git] / dev-libs / jthread / jthread-1.3.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
10 HOMEPAGE="http://research.edm.uhasselt.be/~jori/page/index.php?n=CS.Jthread"
11 SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="static-libs"
17
18 DOCS=( ChangeLog README.TXT TODO doc/manual.tex )
19
20 src_prepare() {
21         # do not build static library, if it is not requested
22         if ! use static-libs; then
23                 sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
24         fi
25 }