dev-db/postgresql: Merge "use /bin/sh (...) for postgres user"
[gentoo.git] / dev-libs / jansson / jansson-2.6.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6 AUTOTOOLS_AUTORECONF=1
7
8 inherit autotools-utils
9
10 DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
11 HOMEPAGE="http://www.digip.org/jansson/"
12 SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
17 IUSE="doc static-libs"
18
19 DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
20 RDEPEND=""
21
22 DOCS=(CHANGES README.rst)
23
24 src_prepare() {
25         sed -ie 's/-Werror//' src/Makefile.am || die
26         autotools-utils_src_prepare
27 }
28
29 src_compile() {
30         autotools-utils_src_compile
31
32         use doc && autotools-utils_src_compile html
33 }
34
35 src_install() {
36         use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
37         autotools-utils_src_install
38 }