dev-libs/liborcus: Fix bashisms in configure.ac, --disable-static
[gentoo.git] / dev-libs / ivykis / ivykis-0.42.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Library for asynchronous I/O readiness notification"
9 HOMEPAGE="https://github.com/buytenh/ivykis"
10 SRC_URI="https://github.com/buytenh/ivykis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
15 IUSE="static-libs"
16
17 PATCHES=(
18         "${FILESDIR}/${PN}-fix-segfault-glibc-2.28.patch" # Bug 675338
19 )
20
21 src_prepare() {
22         default
23
24         eautoreconf
25 }
26
27 src_configure() {
28         econf $(use_enable static-libs static)
29 }
30
31 src_install() {
32         default
33
34         find "${ED}" -name "*.la" -delete || die
35 }