dev-libs/isl: sparc stable wrt bug #693842
[gentoo.git] / dev-libs / isl / isl-0.16.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils multilib-minimal
7
8 DESCRIPTION="A library for manipulating integer points bounded by linear constraints"
9 HOMEPAGE="http://isl.gforge.inria.fr/"
10 SRC_URI="http://isl.gforge.inria.fr/${P}.tar.xz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/15"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
15 IUSE="static-libs"
16
17 RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]"
18 DEPEND="${RDEPEND}
19         app-arch/xz-utils
20         virtual/pkgconfig"
21
22 DOCS=( ChangeLog AUTHORS doc/manual.pdf )
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
26
27         # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
28         # https://groups.google.com/group/isl-development/t/37ad876557e50f2c
29         sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
30 }
31
32 multilib_src_configure() {
33         ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
34 }
35
36 multilib_src_install_all() {
37         einstalldocs
38         prune_libtool_files
39 }