dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / dev-libs / injeqt / injeqt-1.2.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="Dependency injection framework for Qt5"
9 HOMEPAGE="https://github.com/vogel/injeqt"
10 SRC_URI="https://github.com/vogel/injeqt/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="test"
16
17 RDEPEND="
18         >=dev-qt/qtcore-5.4.2:5
19 "
20 DEPEND="${RDEPEND}
21         test? ( >=dev-qt/qttest-5.4.2:5 )
22 "
23
24 # https://github.com/vogel/injeqt/issues/18
25 RESTRICT=test
26
27 PATCHES=( "${FILESDIR}/${P}-gcc7.patch" )
28
29 src_configure() {
30         local mycmakeargs=(
31                 -DDISABLE_EXAMPLES=ON
32                 -DDISABLE_TESTS=$(usex !test)
33         )
34         cmake-utils_src_configure
35 }